PDA

Ver la Versión Completa : Ayuda a elegir sistema operativo



Ferny
01/03/2007, 11:53
Hola a todos

Tengo intención de alquilar próximamente un dedicado para alojar en principio una página web con muchísimo movimiento y un foro smf, aunque quizá alguna página pequeña más No necesito nada complejo, sólo servidor web apache 2 o mejor 2.2, php 5, mysql 5 y email. Calculo que con uno de la serie P4 HT me daría de sobra, pero tengo la duda con el sistema operativo y panel de control a elegir.

Soy totalmente nuevo en la administración total de un servidor, tengo algunos conocimientos pero nunca me metí a administrar mi propio servidor. Actualmente tengo un VPS con paneles de control CPanel y WHM que simplifican mucho la tarea pero no he visto aquí ningún plan que lo ofrezca. En principio creo que lo que más se ajusta a mis necesidades es la distribución Fedora con Plesk 8, ¿sería eso lo recomendable para empezar? Una cosa que no he encontrado es qué distribución de Fedora es, para bajarme y tener a mano la documentación.

Por otro lado me preocupa bastante lo que es el tema de seguridad del servidor. Por mi desconocimiento no me gustaría dejar un sistema abierto a cualquiera. No sé cuánto puede ayudarme plesk en esta tarea. Me gustaría que me diéseis algún consejo o sugerencia para mantener actualizado el software y cerrar posibles agujeros de seguridad.

Un saludo

Gonzalo
01/03/2007, 12:24
el fedora que lleva plesk es el core 4, una version actualemente no soportada ni mantenida, por lo que no tendras facilidad para actualizar.

Para lo que necesitas, webmin con el modulo OVH para el correo te vale.

Lo que te falta de conocimiento lo puedes aprender, un sistema anticuado no tiene solucion.

Ferny
01/03/2007, 17:10
Entonces mejor tomar una Release 2, ¿no?

Otro detalle, las release de seguridad van actualizando el software del servidor según tengo entendido, pero si toco algo en la configuración (por ejemplo cambiar alguna variable en el php.ini o modificar el httpd.conf), ¿al actualizar perderé los cambios? Imagino que no, pero me gustaría confirmarlo. O si tengo que recompilar PHP/apache para añadir alguna función, ¿se pierde en algún momento esa configuración cuando actualice?

Gracias y un saludo

Gonzalo
01/03/2007, 18:44
la release 2 lleva unas modificaciones en las actualizaciones, las cuales se hacen en parte contra OVH. Esto tiene ventajas y desventajas. La ventajas ganan en la mayoria de los casos, y te permite tener unos scripts que actualizan tu maquina segun ovh va creyendo necesario.

las actualziaciones que hagas no intervienen, si son lo que dices, apache, php, etc.Si no, el servidor no seria util, no??

No te digo que sea la mejor opcion, te digo que si solo necesitas algo automatico para correos,etc, release 2 lo hace.

Yo la pedi, pero luego el 99% lo hago por ssh. El modulo webmin-OVH lo uso para dar de alta las cuentas de correo y los dominios.

Te pongo en preaviso,si no has leido el post donde lo dice, que la distribucion de 64b pueden dar un fallo de sql, que aun desconocen el motivo, y parece que en el foro ya hay un afectado.


Lo suyo es que los tecnicos nos tuvieran mas "al dia...".

Ferny
01/03/2007, 20:14
la release 2 lleva unas modificaciones en las actualizaciones, las cuales se hacen en parte contra OVH. Esto tiene ventajas y desventajas. La ventajas ganan en la mayoria de los casos, y te permite tener unos scripts que actualizan tu maquina segun ovh va creyendo necesario.

las actualziaciones que hagas no intervienen, si son lo que dices, apache, php, etc.Si no, el servidor no seria util, no??

Ummm... pero hay algo que no me queda muy claro, pues desconozco cómo trabajan esas actualizaciones. Por ejemplo, supongamos que ahora viene instalado apache 2.0.59 pero por lo que sea me instalo el apache 2.2.4, entonces el día que salga apache 2.0.60 y la actualización de ovh, ¿esta actualización me instalará la versión 2.0.60 o me respetaría la 2.2.4? Claro, que también entiendo que a la versión 2.2.5 me encargaría yo...

Entoces según me dices si recompilo php añadiendo o quitando funciones, eso se respetaría el día que se actualice la versión con el script de ovh ¿cierto?


Te pongo en preaviso,si no has leido el post donde lo dice, que la distribucion de 64b pueden dar un fallo de sql, que aun desconocen el motivo, y parece que en el foro ya hay un afectado.

Pues muchas gracias. Aunque no me afecta pq tomaré la versión de 32 bits, ya que elegiré un procesador P4 HT. Más adelante si me paso a un Core2Duo supongo que será algo que estará más que solucionado jeje.

Un saludo

Gonzalo
01/03/2007, 21:27
yo iba a coger tambien P4, pero no tiene garantia de reemplazo de hard en 4 horas, y por la diferencia, sumando el doble de ancho de banda,pues piye el siguiente.

a ver, las actualizaciones como te decia son scripts, dando ordenes de emerge, por lo que si tu version instalada es superior, emerge la respeta. Lo quee te ofrece OVH con los scripts es un metodo rapido de actualizar XXX cosas que en ese momento se deberian actualizar.Si tu las quieres actualizar a tu rollo, eso ya cada cual.

Ferny
01/03/2007, 21:41
Vale, ahora sí lo entendí jeje. Gracias.

De momento tiraré con el P4, pues tampoco tengo mucho presupuesto. El Core2Duo tiene una pinta estupenda, pero lo tomaré cuando realmente lo necesite.

Saludos

Vidal OVH
02/03/2007, 00:38
Yo te recomendaría la Release 2 (Gentoo) para casi todos los casos, sobre todo si utilizáis un core2duo (por tener 64 bits)

Lo único que justificaría Fedora-Plesk es que necesites un panel de tres niveles (admin-revendedor-cliente).

Tampoco debéis olvidar que la Release 2 (Gentoo) tiene la posibilidad de infogerencia (soporte de nivel 3).

Esto es: un técnico de OVH puede hacer una operación de mantenimiento y/o diagnóstico en el servidor. Estas operaciones son de pago y se da un presupuesto antes de realizarlas, pero en algunos casos puede sacaros de algún apuro.

Respecto a los cambios en los ficheros de configuración (httpd, php, bind, etc) intentad no realizarlos a mano (o hacedlos con mucho cuidado) y pasad por el panel de control OVHm siempre que sea posible.

Si modificáis demasiado un fichero, la actualización puede causar efectos imprevisibles y muy posiblemente algo deje de funcionar correctamente.

Lo mismo para los programas más modernos (no totalmente estables) que los que vienen en Release (lo que nosotros llamamos "fuera de release").

Desde el momento en que un servidor tenga componentes "fuera de release" o haya modificado un fichero de configuración de forma drástica, debe realizar todas las actualizaciones a mano y evitar el script automático.

Un saludo