PDA

Ver la Versión Completa : No puedo instalar el Zend ni pagando!



hawork
16/05/2008, 18:46
He adquirido hace un par de meses un servidor EG 2008 con sistema Gentoo 2006.0 - 64 bits.

El caso es que me sorprendió que no viniera con el zend optimizer instalado. Tras seguir algo de las guías ovh (no al pie de la letra porque eran para plesk) y tras googlear mucho pude intentar instalarlo.

Siempre la instalación me decía que había ido bien pero luego al hacer un "php -v" no me salía el optimizer (ni haciendo reboot ni nada).

Desesperado de haberme gastado un pastón en un servidor y que no me sirva para nada (mis aplicaciones necesitan zend optimizer), decidí hacer uso de mi infogerencia gratuita (los 15mins).

Me dijeron que tenía que pagar 45€ (igual eran 44,50 no lo recuerdo) porque en 15 mins no daba tiempo (¿?). En fin... como realmente lo necesito dije que vale, que los pagaba...

Al poco tiempo recibo un mensaje en francés que decía que no habían sido capaces de instalarlo y que me devolverían el dinero de la infogerencia.

El zend optimizer es algo muy simple de instalar por lo que leo y, que yo no sea capaz, me lo creo. Pero que un técnico no pueda hacerlo?¿? esto me huele a que tengo un servidor defectuoso o algo así porque si no... ya me contaréis...

Me estoy planteando dejar ovh sólo por esta tontería y no puedo entender cómo pueden pasar tanto de una chorrada así.

A parte de dejar este mensaje públicamente por si algún miembro del equipo de ovh me puede echar una mano, también me gustaría que si alguien lo ha instalado me diga si hizo algo especial (alguna ruta extraña para el php.ini o algo).

Muchas gracias y saludos a todos,


Editado: acabo de leer este mensaje en otro hilo:

Vidal_OVH
El Ixed no es una extensión de PHP, sino una extensión del Zend Optimizer.

Instala el Zend Optimizer en la Release2 (es algo bastante fácil) y luego añade la extensión al directorio del Zend.


Yo tengo la release 2...

Vidal OVH
29/05/2008, 09:12
El Zend Engine está instalado, pero no el Optimizer.

Igualmente hay otros módulos de Zend que se pueden instalar sobre el Engine.

- Optimizer
- Ioncube
- Ixed
-....

Para instalar Optimizer para PHP5 con Release 2:


# wget http://downloads.zend.com/optimizer/3.2.0/ZendOptimizer-3.2.0-linux-glibc21-i386.tar.gz

# tar -zxvf ZendOptimizer-3.2.0-linux-glibc21-i386.tar.gz

# ./ZendOptimizer-3.2.0-linux-glibc21-i386/install

Opciones :

- Please specify the location for installing Zend Optimizer:
/usr/local/php5/include/php/Zend

- Confirm the location of your php.ini file :
/usr/local/lib/php5

- Specify the full path to the Apache control utility (apachectl)
/usr/local/apache/bin/apachectl


# php5 -v
PHP 5.2.5-pl1-gentoo (cgi)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
with Zend Extension Manager v1.0.11, Copyright (c) 2003-2006, by Zend Technologies
with Zend Optimizer v3.2.0, Copyright (c) 1998-2006, by Zend Technologies