PDA

Ver la Versión Completa : Consumo masivo CPU - KEMSIRVE 2008 + W2003 + Apache



EFC
25/05/2008, 18:43
Tengo un KEMSIRVE 2008 con Windows 2003 Server, he migrado mis webs y se me queda el sistema atascado con picos de consumo 100% de CPU de 15-30 segundos.
El software del servidor web es un WAMP (Windows Apache MySql PHP). Lo he estado usando en mi viejo Start 100M sin problemas, al migrar al KS debería ir sobrado de recursos pero no consigo hacerlo funcionar.
Los procesos http.exe y mysql-nt.exe consumen el 100% de la cpu durante picos de unos 20 segundos que se producen constantemente.
El mismo Apache con las mismas webs y la misma configuración me funciona perfectamente en un servidor casero con conexión de cable-modem en un portatil chiquitito con 512mb de memoria.
He probado a reinstalar el software, he reinstalado el Windows, he detenido los servicios y procesos innecesarios del windows, he limpiado el registro. Todo sin éxito.

Cuando pongo a funcionar una copia exacta del servidor web en casa, habiendo hecho la migración en los DNS, el server corre sin problemas.

¿Alguna idea?

EFC
28/05/2008, 11:27
Ya tengo mas datos y algunas conclusiones.

No hay errores en la configuración de windows ni del software servidor.
La máquina funciona correctamente, el problema es simplemente que tiene un rendimiento inferior al que yo esperaba, inferior también a mi antiguo Start 100M que tenía la mitad de memoria.

Los picos de consumo se producen por las peticiones al server, cuando se reciben 5 o mas peticiones simultaneas la CPU se satura y queda funcionando al 100% varios segundos.

No recomiendo este modelo de servidor con Windows para alojar sitios pesados, con mucho tráfico o con CMS`s tipo Joomla.

En mi caso tengo unas 40 webs bajo WAMP + Joomla y sirviendo unas 5.000-8.000 páginas diarias.

xico1984
28/05/2008, 11:48
Ya tengo mas datos y algunas conclusiones.

No hay errores en la configuración de windows ni del software servidor.
La máquina funciona correctamente, el problema es simplemente que tiene un rendimiento inferior al que yo esperaba, inferior también a mi antiguo Start 100M que tenía la mitad de memoria.

Los picos de consumo se producen por las peticiones al server, cuando se reciben 5 o mas peticiones simultaneas la CPU se satura y queda funcionando al 100% varios segundos.

No recomiendo este modelo de servidor con Windows para alojar sitios pesados, con mucho tráfico o con CMS`s tipo Joomla.

En mi caso tengo unas 40 webs bajo WAMP + Joomla y sirviendo unas 5.000-8.000 páginas diarias.

Han aumentado al memoria, pero el procesador del Start 100M, es más rápido que el Kemsirve.. Para eso pertenece a una categoría inferior..
Deberías de haberte cogido su homólogo, que creo que es el XL.

Un saludo